Note to self: installing compass on Ubuntu Server

Fri, 06/28/2013 - 18:11 -- Kyle Skrinak

I've done this at least twice now

sudo apt-get install ruby-compass

Real easy, right? Wrong. Ruby blogs go ballistic over how awesome rvm, how flawed the debian method for managing ruby is. Rvm is awesome because since you can run different versions of ruby during development; whatever.

Hey, Ms. Fancypants, I just want to compile sass files.

So, next time I install compass on ubuntu, these steps (which uses rvm) worked great.

Comments

Submitted by Mike Gering (not verified) on

I did the standard apt-get install on Ubuntu (12.04) and lived with a silly deprecation warning until Kyle pointed me here for advice on how to properly install Ruby for using Compass. Worked like a champ. Thanks, Kyle!